import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((http|https)\\:\\/\\/|)([\\w|\\-]+\\.)+\\w+($|[\\w\\-\\/\\.]+$|[\\w\\/\\.]+\\?[\\w\\=\\&\\.]+$)";
final String string = "http://www3.hilton.com/en/hotels\n"
+ "http://www3.hilt-on.com/en/hot-els/unite\n"
+ "http://www3.hilton.com/en/hotels/united-kingdom/the-waldorf-hilton-london-LONWAHI/index.html";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}