// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^((http|https)\:\/\/|)([\w|\-]+\.)+\w+($|[\w\-\/\.]+$|[\w\/\.]+\?[\w\=\&\.]+$)").unwrap();
let string = "http://www3.hilton.com/en/hotels
http://www3.hilt-on.com/en/hot-els/unite
http://www3.hilton.com/en/hotels/united-kingdom/the-waldorf-hilton-london-LONWAHI/index.html";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}