const regex = /^((http|https)\:\/\/|)([\w|\-]+\.)+\w+($|[\w\-\/\.]+$|[\w\/\.]+\?[\w\=\&\.]+$)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((http|https)\\:\\\/\\\/|)([\\w|\\-]+\\.)+\\w+($|[\\w\\-\\\/\\.]+$|[\\w\\\/\\.]+\\?[\\w\\=\\&\\.]+$)', 'gmi')
const str = `http://www3.hilton.com/en/hotels
http://www3.hilt-on.com/en/hot-els/unite
http://www3.hilton.com/en/hotels/united-kingdom/the-waldorf-hilton-london-LONWAHI/index.html`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}