#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d\d (\d\d):(\d\d):.*\R.* (?!\1)\d+:\2"
Local $sString = "2024-01-19 13:09:22.616 Message="one"" & @CRLF & _
"2024-01-19 13:09:22.721 Message="two"" & @CRLF & _
"2024-01-19 14:09:22.814 Message="three"" & @CRLF & _
"2024-01-19 13:09:22.902 Message="four""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")