use strict;
my $str = '2024-01-19 13:09:22.616 Message="one"
2024-01-19 13:09:22.721 Message="two"
2024-01-19 14:09:22.814 Message="three"
2024-01-19 13:09:22.902 Message="four"';
my $regex = qr/\d\d (\d\d):(\d\d):.*\R.* (?!\1)\d+:\2/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}