import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d\\d (\\d\\d):(\\d\\d):.*\\R.* (?!\\1)\\d+:\\2";
final String string = "2024-01-19 13:09:22.616 Message=\"one\"\n"
+ "2024-01-19 13:09:22.721 Message=\"two\"\n"
+ "2024-01-19 14:09:22.814 Message=\"three\"\n"
+ "2024-01-19 13:09:22.902 Message=\"four\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}