const regex = /\d\d (\d\d):(\d\d):.*\R.* (?!\1)\d+:\2/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d\\d (\\d\\d):(\\d\\d):.*\\R.* (?!\\1)\\d+:\\2', 'gm')
const str = `2024-01-19 13:09:22.616 Message="one"
2024-01-19 13:09:22.721 Message="two"
2024-01-19 14:09:22.814 Message="three"
2024-01-19 13:09:22.902 Message="four"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}