package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)class\s(\w+)|def\s(\w+)`)
var str = `class MyClass_1(...):
...
def method1_of_first_class(self):
...
def method2_of_first_class(self):
...
def method3_of_first_class(self):
...
class MyClass_2(...):
...
def method1_of_second_class(self):
...
def method2_of_second_class(self):
...
def method3_of_second_class(self):
...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}