import re
regex = re.compile(r"class\s(\w+)|def\s(\w+)", flags=re.MULTILINE)
test_str = ("class MyClass_1(...):\n"
" ...\n"
" def method1_of_first_class(self):\n"
" ...\n\n"
" def method2_of_first_class(self):\n"
" ...\n\n"
" def method3_of_first_class(self):\n"
" ...\n\n"
"class MyClass_2(...):\n"
" ...\n"
" def method1_of_second_class(self):\n"
" ...\n\n"
" def method2_of_second_class(self):\n"
" ...\n\n"
" def method3_of_second_class(self):\n"
" ...")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")