import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "class\\s(\\w+)|def\\s(\\w+)";
final String string = "class MyClass_1(...):\n"
+ " ...\n"
+ " def method1_of_first_class(self):\n"
+ " ...\n\n"
+ " def method2_of_first_class(self):\n"
+ " ...\n\n"
+ " def method3_of_first_class(self):\n"
+ " ...\n\n"
+ "class MyClass_2(...):\n"
+ " ...\n"
+ " def method1_of_second_class(self):\n"
+ " ...\n\n"
+ " def method2_of_second_class(self):\n"
+ " ...\n\n"
+ " def method3_of_second_class(self):\n"
+ " ...";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}