re = /class\s(\w+)|def\s(\w+)/m
str = 'class MyClass_1(...):
...
def method1_of_first_class(self):
...
def method2_of_first_class(self):
...
def method3_of_first_class(self):
...
class MyClass_2(...):
...
def method1_of_second_class(self):
...
def method2_of_second_class(self):
...
def method3_of_second_class(self):
...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end