# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/("[^"\n]*)\r?\n(?!(([^"]*"){2})*[^"]*$)/$1<br>/g;t' <<< "\"abc\",\"def
ghi\",\"klm
pqr\", \"xyz\"
\"123\",\"sdfsdf\",\"sdfs\"
"