using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""[^""\n]*)\r?\n(?!(([^""]*""){2})*[^""]*$)";
string substitution = @"$1<br>";
string input = @"""abc"",""def
ghi"",""klm
pqr"", ""xyz""
""123"",""sdfsdf"",""sdfs""
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}