re = /("[^"\n]*)\r?\n(?!(([^"]*"){2})*[^"]*$)/
str = '"abc","def
ghi","klm
pqr", "xyz"
"123","sdfsdf","sdfs"
'
subst = '$1<br>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result