import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"[^\"\\n]*)\\r?\\n(?!(([^\"]*\"){2})*[^\"]*$)";
final String string = "\"abc\",\"def \n"
+ " ghi\",\"klm \n"
+ "pqr\", \"xyz\"\n"
+ "\"123\",\"sdfsdf\",\"sdfs\"\n\n\n";
final String subst = "$1<br>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}