#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)define\(\s*(["'])(?P<key>.+?(?=\1))\1\s*," & @CRLF & _
"\s*(["'])(?P<value>.+?)(?=\3)(?<!\\)\3"
Local $sString = "define("My_KEY", "My_Value l");" & @CRLF & _
"define('My_KEY', 'My_Value');" & @CRLF & _
"define( 'My_KEY' , "My_Value" );" & @CRLF & _
"define( 'My_KEY' , 'My\'_\'Value' );" & @CRLF & _
"define( 'My_KEY' , "My'_'Value" );"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")