import re
regex = re.compile(r"""
define\(\s*(["'])(?P<key>.+?(?=\1))\1\s*,
\s*(["'])(?P<value>.+?)(?=\3)(?<!\\)\3
""", flags=re.VERBOSE)
test_str = ("define(\"My_KEY\", \"My_Value l\");\n"
"define('My_KEY', 'My_Value');\n"
"define( 'My_KEY' , \"My_Value\" );\n"
"define( 'My_KEY' , 'My\\'_\\'Value' );\n"
"define( 'My_KEY' , \"My'_'Value\" );")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")