using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"define\(\s*([""'])(?P<key>.+?(?=\1))\1\s*,
\s*([""'])(?P<value>.+?)(?=\3)(?<!\\)\3";
string input = @"define(""My_KEY"", ""My_Value l"");
define('My_KEY', 'My_Value');
define( 'My_KEY' , ""My_Value"" );
define( 'My_KEY' , 'My\'_\'Value' );
define( 'My_KEY' , ""My'_'Value"" );";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}