const regex = new RegExp('define\\(\\s*(["\\'])(?P<key>.+?(?=\\1))\\1\\s*,
\\s*(["\\'])(?P<value>.+?)(?=\\3)(?<!\\\\)\\3', 'g')
const str = `define("My_KEY", "My_Value l");
define('My_KEY', 'My_Value');
define( 'My_KEY' , "My_Value" );
define( 'My_KEY' , 'My\\'_\\'Value' );
define( 'My_KEY' , "My'_'Value" );`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}