import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "define\\(\\s*([\"'])(?P<key>.+?(?=\\1))\\1\\s*,\n"
+ "\\s*([\"'])(?P<value>.+?)(?=\\3)(?<!\\\\)\\3";
final String string = "define(\"My_KEY\", \"My_Value l\");\n"
+ "define('My_KEY', 'My_Value');\n"
+ "define( 'My_KEY' , \"My_Value\" );\n"
+ "define( 'My_KEY' , 'My\\'_\\'Value' );\n"
+ "define( 'My_KEY' , \"My'_'Value\" );";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}