#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^-\n]+)[^-\n]{2}(?:-.*)?$"
Local $sString = "abcde" & @CRLF & _
"jklmno-pqrs" & @CRLF & _
"abcd" & @CRLF & _
"jklmno----pqrs" & @CRLF & _
"jklmno----abdapqrs" & @CRLF & _
"a-" & @CRLF & _
"aa--" & @CRLF & _
"aaa---" & @CRLF & _
"----" & @CRLF & _
"mmmmmmmmmmmmmmmmmm------" & @CRLF & _
"-a-a-a-aaaa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")