package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^-\n]+)[^-\n]{2}(?:-.*)?$`)
var str = `abcde
jklmno-pqrs
abcd
jklmno----pqrs
jklmno----abdapqrs
a-
aa--
aaa---
----
mmmmmmmmmmmmmmmmmm------
-a-a-a-aaaa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}