$re = '/^([^-\n]+)[^-\n]{2}(?:-.*)?$/m';
$str = 'abcde
jklmno-pqrs
abcd
jklmno----pqrs
jklmno----abdapqrs
a-
aa--
aaa---
----
mmmmmmmmmmmmmmmmmm------
-a-a-a-aaaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);