re = /^([^-\n]+)[^-\n]{2}(?:-.*)?$/m
str = 'abcde
jklmno-pqrs
abcd
jklmno----pqrs
jklmno----abdapqrs
a-
aa--
aaa---
----
mmmmmmmmmmmmmmmmmm------
-a-a-a-aaaa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end