import re
regex = re.compile(r"^([^-\n]+)[^-\n]{2}(?:-.*)?$", flags=re.MULTILINE)
test_str = ("abcde\n"
"jklmno-pqrs\n"
"abcd\n"
"jklmno----pqrs\n"
"jklmno----abdapqrs\n"
"a-\n"
"aa--\n"
"aaa---\n"
"----\n"
"mmmmmmmmmmmmmmmmmm------\n"
"-a-a-a-aaaa")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")