#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([N-R][\w]{3}(\s?)){2})$"
Local $sString = "Rand, NaCr" & @CRLF & _
"Minden Blake" & @CRLF & _
"Edward Darling" & @CRLF & _
"Robert Fumerton" & @CRLF & _
"Alex Roni" & @CRLF & _
"ToMmy Rid" & @CRLF & _
"Christian Olav" & @CRLF & _
"JohHn PeTter" & @CRLF & _
"Flara Sbastian" & @CRLF & _
"Hovard Kai" & @CRLF & _
"Runne Nervin" & @CRLF & _
"OlaAf RoOni" & @CRLF & _
"Olaf Roni"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")