const regex = /^(([N-R][\w]{3}(\s?)){2})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([N-R][\\w]{3}(\\s?)){2})$', 'gm')
const str = `Rand, NaCr
Minden Blake
Edward Darling
Robert Fumerton
Alex Roni
ToMmy Rid
Christian Olav
JohHn PeTter
Flara Sbastian
Hovard Kai
Runne Nervin
OlaAf RoOni
Olaf Roni`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}