// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(([N-R][\w]{3}(\s?)){2})$").unwrap();
let string = "Rand, NaCr
Minden Blake
Edward Darling
Robert Fumerton
Alex Roni
ToMmy Rid
Christian Olav
JohHn PeTter
Flara Sbastian
Hovard Kai
Runne Nervin
OlaAf RoOni
Olaf Roni";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}