import re
regex = re.compile(r"^(([N-R][\w]{3}(\s?)){2})$", flags=re.MULTILINE)
test_str = ("Rand, NaCr\n"
"Minden Blake\n"
"Edward Darling\n"
"Robert Fumerton\n"
"Alex Roni\n"
"ToMmy Rid\n"
"Christian Olav\n"
"JohHn PeTter\n"
"Flara Sbastian\n"
"Hovard Kai\n"
"Runne Nervin\n"
"OlaAf RoOni\n"
"Olaf Roni")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")