re = /^(([N-R][\w]{3}(\s?)){2})$/m
str = 'Rand, NaCr
Minden Blake
Edward Darling
Robert Fumerton
Alex Roni
ToMmy Rid
Christian Olav
JohHn PeTter
Flara Sbastian
Hovard Kai
Runne Nervin
OlaAf RoOni
Olaf Roni'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end