#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:,?(".+?"))|(?:,?(.+?),?)"
Local $sString = "A,B,"Hi,There",C,D,"More,here",E,F,"Test test""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)