package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:,?(".+?"))|(?:,?(.+?),?)`)
var str = `A,B,"Hi,There",C,D,"More,here",E,F,"Test test"`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}