use strict;
my $str = 'A,B,"Hi,There",C,D,"More,here",E,F,"Test test"';
my $regex = qr/(?:,?(".+?"))|(?:,?(.+?),?)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";