re = /(?:,?(".+?"))|(?:,?(.+?),?)/
str = 'A,B,"Hi,There",C,D,"More,here",E,F,"Test test"'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result