$re = '/(?:,?(".+?"))|(?:,?(.+?),?)/';
$str = 'A,B,"Hi,There",C,D,"More,here",E,F,"Test test"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;