using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bhttp(?:s)?(?::|;)\/\/(?!.+\.\.)(?'domain'.+?\..+?(?=\/|$| )).*?(?=$| )";
string input = @"http://regex101.com/r/mH1fN5/#wgt
http://regex101.com/r/fW0vZ2
https://regex101.com/r/noweqf/1253125321532153512312351352435 joi
http;//4.4..4.4.4.4.wef
http;//a.3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}