use strict;
my $str = 'http://regex101.com/r/mH1fN5/#wgt
http://regex101.com/r/fW0vZ2
https://regex101.com/r/noweqf/1253125321532153512312351352435 joi
http;//4.4..4.4.4.4.wef
http;//a.3';
my $regex = qr/\bhttp(?:s)?(?::|;)\/\/(?!.+\.\.)(?'domain'.+?\..+?(?=\/|$| )).*?(?=$| )/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}