import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bhttp(?:s)?(?::|;)\\/\\/(?!.+\\.\\.)(?'domain'.+?\\..+?(?=\\/|$| )).*?(?=$| )";
final String string = "http://regex101.com/r/mH1fN5/#wgt\n"
+ "http://regex101.com/r/fW0vZ2\n"
+ "https://regex101.com/r/noweqf/1253125321532153512312351352435 joi\n"
+ "http;//4.4..4.4.4.4.wef\n"
+ "http;//a.3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}