re = /\bhttp(?:s)?(?::|;)\/\/(?!.+\.\.)(?'domain'.+?\..+?(?=\/|$| )).*?(?=$| )/m
str = 'http://regex101.com/r/mH1fN5/#wgt
http://regex101.com/r/fW0vZ2
https://regex101.com/r/noweqf/1253125321532153512312351352435 joi
http;//4.4..4.4.4.4.wef
http;//a.3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end