$re = '/\bhttp(?:s)?(?::|;)\/\/(?!.+\.\.)(?\'domain\'.+?\..+?(?=\/|$| )).*?(?=$| )/m';
$str = 'http://regex101.com/r/mH1fN5/#wgt
http://regex101.com/r/fW0vZ2
https://regex101.com/r/noweqf/1253125321532153512312351352435 joi
http;//4.4..4.4.4.4.wef
http;//a.3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);