# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:https?:\\/\\/|\\/[a-z]{2}_[A-Z]{2}|[?&]tic=[^&?\n]*)//gm;t' <<< "https://pinball.globalzone.com/en_US/home?tic=1-dj33jl-dj33jl&goToRegisterNow=true
https://pinball.globalzone.com/en_US/home?goToRegisterNow=true&tic=1-dj33jl-dj33jl
https://pinball.globalzone.com/en_US/forgottenPassword"