re = /(?:https?:\/\/|\/[a-z]{2}_[A-Z]{2}|[?&]tic=[^&?\n]*)/m
str = 'https://pinball.globalzone.com/en_US/home?tic=1-dj33jl-dj33jl&goToRegisterNow=true
https://pinball.globalzone.com/en_US/home?goToRegisterNow=true&tic=1-dj33jl-dj33jl
https://pinball.globalzone.com/en_US/forgottenPassword'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result