package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:https?:\/\/|\/[a-z]{2}_[A-Z]{2}|[?&]tic=[^&?\n]*)`)
var str = `https://pinball.globalzone.com/en_US/home?tic=1-dj33jl-dj33jl&goToRegisterNow=true
https://pinball.globalzone.com/en_US/home?goToRegisterNow=true&tic=1-dj33jl-dj33jl
https://pinball.globalzone.com/en_US/forgottenPassword`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}