import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:https?:\\/\\/|\\/[a-z]{2}_[A-Z]{2}|[?&]tic=[^&?\\n]*)";
final String string = "https://pinball.globalzone.com/en_US/home?tic=1-dj33jl-dj33jl&goToRegisterNow=true\n"
+ "https://pinball.globalzone.com/en_US/home?goToRegisterNow=true&tic=1-dj33jl-dj33jl\n"
+ "https://pinball.globalzone.com/en_US/forgottenPassword";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}