package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(0[0-9]{3}(\-|)[0-9]{4}(\-|)[0-9]{4}(\-|)[0-9]{4})`)
var str = `1234-5678-1234-5678
0548-1489-5845-7452
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}