const regex = /(0[0-9]{3}(\-|)[0-9]{4}(\-|)[0-9]{4}(\-|)[0-9]{4})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(0[0-9]{3}(\\-|)[0-9]{4}(\\-|)[0-9]{4}(\\-|)[0-9]{4})', '')
const str = `1234-5678-1234-5678
0548-1489-5845-7452
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}