import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(0[0-9]{3}(\\-|)[0-9]{4}(\\-|)[0-9]{4}(\\-|)[0-9]{4})";
final String string = "1234-5678-1234-5678\n"
+ "0548-1489-5845-7452\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}