// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(0[0-9]{3}(\-|)[0-9]{4}(\-|)[0-9]{4}(\-|)[0-9]{4})").unwrap();
let string = "1234-5678-1234-5678
0548-1489-5845-7452
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}