re = /(0[0-9]{3}(\-|)[0-9]{4}(\-|)[0-9]{4}(\-|)[0-9]{4})/
str = '1234-5678-1234-5678
0548-1489-5845-7452
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end