package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$\{.*?\}`)
var str = `{
"type" : "id",
"id" : ${idOf('/tar/check/inof/high1')},
"details" : [
{
"name" : "Sanio",
"sig" : "DA123QW"
},
{
"name" : "Tarer",
"sig" : "BAWE3QW"
},
{
"name" : "Kadek",
"sig" : "KSWE2J"
},
]
},`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}